Tuesday, May 22, 2012

[Ubuntu]10.04 Parital Upgrade Error

Error Message:subprocess installed pre-removal script returned error exit status 2
Package : adobe-flashplugin

Removing adobe-flashplugin ...
update-alternatives: error: no alternatives for iceape-flashplugin.
update-alternatives: error: no alternatives for iceape-flashplugin.
dpkg: error processing adobe-flashplugin (--remove):
 subprocess installed pre-removal script returned error exit status 2
postinst called with argument `abort-remove'
dpkg: error while cleaning up:
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 adobe-flashplugin
E: Sub-process /usr/bin/dpkg returned an error code (1)

Solution:
1. Backup /var/lib/dpkg/status
2. Edit /var/lib/dpkg/status, and remove Package adobe-flashplugin

Reference:http://www.khattam.info/solved-subprocess-pre-removal-script-returned-error-exit-status-2-error-2009-08-04.html